CVE-2024-23646: pimcore admin-ui-classic-bundle · SQL Injection
Affects pimcore admin-ui-classic-bundleSource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 1.3.2 soon.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.9% chance of exploitation in 30 days – higher than 62% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.3.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 24 Jan 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade pimcore/admin-ui-classic-bundle to 1.3.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubpimcore/admin-ui-classic-bundlepkg:github/pimcore/admin-ui-classic-bundleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Immediate upgrade of the Pimcore Admin Classic Bundle to version 1.3.2 or later is the primary and most effective mitigation.
- Restrict backend user permissions strictly, ensuring only trusted users have access to the Admin Classic Bundle interface, minimizing the risk of exploitation by low-privilege users.
- Implement network-level access controls such as VPNs or IP whitelisting to limit access to the Pimcore backend interface.
- Monitor database logs and Pimcore application logs for unusual SQL queries or privilege escalations indicative of exploitation attempts.
- Employ Web Application Firewalls (WAFs) with custom rules to detect and block SQL injection patterns targeting the 'selectedIds' parameter.
- Conduct regular security audits and penetration testing focused on backend interfaces to detect similar injection vulnerabilities.
- Ensure backups of Pimcore data are current and tested to enable recovery in case of data tampering or loss.
Description
Pimcore's Admin Classic Bundle provides a backend user interface for Pimcore. The application allows users to create zip files from available files on the site. In the 1.x branch prior to version 1.3.2, parameter `selectedIds` is susceptible to SQL Injection. Any backend user with very basic permissions can execute arbitrary SQL statements and thus alter any data or escalate their privileges to at least admin level. Version 1.3.2 contains a fix for this issue.
References
- github.com/pimcore/admin-ui-classic-bundle/security/advisories/GHSA-cwx6-4wmf-c6xv (opens in a new tab)
- github.com/pimcore/admin-ui-classic-bundle/commit/363afef29496cc40a8b863c2ca2338979fcf50a8 (opens in a new tab)
- github.com/pimcore/admin-ui-classic-bundle/blob/1.x/src/Controller/Admin/Asset/AssetController.php (opens in a new tab)
- github.com/pimcore/admin-ui-classic-bundle/blob/1.x/src/Controller/Admin/Asset/AssetController.php (opens in a new tab)
- github.com/pimcore/admin-ui-classic-bundle/releases/tag/v1.3.2 (opens in a new tab)