CVE-2025-10871: GitLab · Missing Authorization
Affects GitLabSource CVE Database V5
Not known to be exploited · CVSS 3.8 Low · fixed in 18.4.1 : update GitLab when convenient.
Data as of 3 Nov 2026, 22:57 UTC
Thin evidence
One scorer or none| CNA (GitLab) | CVSS 3.1 | 3.8 |
|---|
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Total control over the software or total information disclosure
CISA SSVC assessment, 2025-09-27.
- Patch
- Available – fixed in 18.4.1, 18.3.3, 18.2.7
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 26 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade GitLab to 18.4.1, 18.3.3 or 18.2.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| GitLabGitLab | Affected
| Fixed in
|
| GitLabGitLab | Affected
| Fixed in
|
| GitLabGitLab | Affected
| Fixed in
|
CPE configurations (1)
cpe:2.3:a:gitlab:gitlab:*:*:*:*:*:*:*:*
AI-suggested
Upgrade affected GitLab EE instances to versions 18.2.7, 18.3.3, or 18.4.1 or later, where the vulnerability has been fixed. No other mitigation or temporary workaround is indicated.
Description
CVE-2025-10871 is a missing authorization vulnerability in GitLab EE affecting versions from 16.6 before 18.2.7, 18.3 before 18.3.3, and 18.4 before 18.4.1. It allows Project Maintainers to assign custom roles to users with permissions exceeding their own, effectively escalating privileges. The issue has been fixed in versions 18.2.7, 18.3.3, and 18.4.1.