Skip to main content
VulnerabilityPublished Updated

CVE-2025-2938: GitLab · Business Logic Errors

Affects GitLabSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 3.1 Low · fixed in 18.1.1 : update GitLab when convenient.

Data as of 3 Nov 2026, 22:57 UTC

CVSS 3.1 base score
3.1Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitLab)CVSS 3.13.1
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2025-06-27.

Patch
Available – fixed in 18.1.1, 18.0.3, 17.11.5
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade GitLab to 18.1.1, 18.0.3 or 17.11.5.

Affected software

ProductAffectedFixed in
GitLabGitLabAffected
  • >=18.1 <18.1.1
Fixed in
  • 18.1.1
GitLabGitLabAffected
  • >=18.0 <18.0.3
Fixed in
  • 18.0.3
GitLabGitLabAffected
  • >=17.3 <17.11.5
Fixed in
  • 17.11.5

CPE configurations (1)

  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:*:*:*:*

AI-suggested

Upgrade GitLab CE/EE to versions 17.11.5, 18.0.3, or 18.1.1 or later where this issue is fixed. No additional mitigations are required once patched.

Description

CVE-2025-2938 is a business logic vulnerability in GitLab CE/EE that affects versions from 17.3 before 17.11.5, 18.0 before 18.0.3, and 18.1 before 18.1.1. The flaw allows authenticated users to gain elevated project privileges due to unintended permission grants caused by role modifications during the approval process. This issue has been fixed in versions 17.11.5, 18.0.3, and 18.1.1.

References

Community reviews

Loading reviews…