Skip to main content
VulnerabilityPublished Updated

CVE-2025-8405: GitLab · Improper Encoding or Escaping of Output

Affects GitLabSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.7 High · fixed in 18.6.2 : patch GitLab soon.

Data as of 3 Nov 2026, 22:58 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitLab)CVSS 3.17.7
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2025-12-12.

Patch
Available – fixed in 18.6.2, 18.5.4, 18.4.6
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade GitLab to 18.6.2, 18.5.4 or 18.4.6.

Affected software

ProductAffectedFixed in
GitLabGitLabAffected
  • >=18.6 <18.6.2
Fixed in
  • 18.6.2
GitLabGitLabAffected
  • >=18.5 <18.5.4
Fixed in
  • 18.5.4
GitLabGitLabAffected
  • >=17.1 <18.4.6
Fixed in
  • 18.4.6

CPE configurations (1)

  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:*:*:*:*

Description

GitLab has remediated a security issue in GitLab CE/EE affecting all versions from 17.1 before 18.4.6, 18.5 before 18.5.4, and 18.6 before 18.6.2 that could have allowed an authenticated user to perform unauthorized actions on behalf of other users by injecting malicious HTML into vulnerability code flow displays.

References

Community reviews

Loading reviews…