Skip to main content
VulnerabilityPublished

CVE-2025-12741: Google Cloud Looker · Improper Input Validation

Affects Google Cloud LookerSource CVE Database V5

0

Not known to be exploited · CVSS 7.7 High.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/U:Red

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Google Cloud LookerAffected
  • =0
Fixed in–

AI-suggested

European organizations using self-hosted Looker must urgently upgrade to the patched versions listed (24.12.108+, 24.18.200+, 25.0.78+, 25.6.65+, 25.8.47+, 25.12.10+, 25.14+). Beyond patching, restrict Developer role assignments strictly to trusted personnel and regularly audit role permissions to minimize risk exposure. Implement network segmentation to isolate Looker instances from critical infrastructure and monitor LookML changes for unusual or unauthorized modifications. Employ runtime application self-protection (RASP) or web application firewalls (WAF) capable of detecting command injection patterns. Conduct regular security training for developers and administrators on secure LookML practices. Finally, maintain comprehensive logging and alerting to detect suspicious activities promptly.

Description

CVE-2025-12741 is a high-severity vulnerability in Google Cloud Looker affecting self-hosted instances. A user with Developer role can exploit improper input validation in LookML when creating a database connection using the Denodo driver to execute malicious commands. Looker-hosted instances have been mitigated and require no user action, but self-hosted deployments must upgrade to patched versions immediately. The vulnerability has a CVSS 4.0 score of 7.7, indicating high impact on confidentiality, integrity, and availability. No known exploits are currently in the wild. Organizations using self-hosted Looker should prioritize patching to prevent potential command injection attacks that could compromise sensitive data and system integrity.

References

Community reviews

Loading reviews…