Skip to main content
CVE-2025-30145VulnerabilityPublished

CVE-2025-30145: geoserver · Infinite Loop

Affects geoserverSource CVE Database V5

0

Not known to be exploited · CVSS 7.5 High : upgrade to 2.25.7 soon.

Data as of 26 Oct 2026, 07:57 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.25.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade geoserver/geoserver to 2.25.7.

Affected software

ProductAffectedFixed in
GitHubgeoserver/geoserverpkg:github/geoserver/geoserverOther threatsAffected
  • <2.25.7
Fixed in
  • 2.25.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate this vulnerability, European organizations should promptly upgrade GeoServer installations to versions 2.27.0, 2.26.3, or 2.25.7 where the vulnerability is fixed. If immediate upgrading is not feasible, disabling WMS dynamic styling and the Jiffle process is recommended to prevent execution of malicious scripts. Network-level protections such as firewall rules restricting access to GeoServer management interfaces and WMS/WPS endpoints to trusted IPs can reduce exposure. Monitoring GeoServer logs for unusual or repeated Jiffle script executions can help detect attempted exploitation. Additionally, implementing rate limiting and anomaly detection on GeoServer services may help mitigate denial of service attempts. Organizations should also review and harden access controls and ensure GeoServer instances are not unnecessarily exposed to the public internet. Regular vulnerability scanning and patch management processes should be enforced to promptly identify and remediate such issues.

Description

GeoServer is an open source server that allows users to share and edit geospatial data. Malicious Jiffle scripts can be executed by GeoServer, either as a rendering transformation in WMS dynamic styles or as a WPS process, that can enter an infinite loop to trigger denial of service. This vulnerability is fixed in 2.27.0, 2.26.3, and 2.25.7. This vulnerability can be mitigated by disabling WMS dynamic styling and the Jiffle process.

References

Community reviews

Loading reviews…