Skip to main content
VulnerabilityPublished

CVE-2025-48490: Lomkit laravel-rest-api · Improper Input Validation

Affects Lomkit laravel-rest-apiSource CVE Database V5

0

Not known to be exploited · CVSS 6.6 Medium : upgrade to 2.13.0 when convenient.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 4.0 base score
6.6Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.13.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade lomkit/laravel-rest-api to 2.13.0.

Affected software

ProductAffectedFixed in
GitHublomkit/laravel-rest-apipkg:github/lomkit/laravel-rest-apiOther threatsAffected
  • <2.13.0
Fixed in
  • 2.13.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately audit their use of Lomkit laravel-rest-api and verify the version in use. Upgrading to version 2.13.0 or later is the primary and most effective mitigation. Where immediate upgrade is not feasible, organizations should implement strict input validation at multiple layers, including web application firewalls (WAFs) with custom rules to detect anomalous or unexpected parameters. API gateways should enforce schema validation and reject requests with unexpected or duplicate parameters. Logging and monitoring should be enhanced to detect unusual API request patterns that may indicate exploitation attempts. Additionally, organizations should conduct thorough security testing of their APIs, including fuzz testing and validation rule verification, to identify any residual validation bypass issues. Developers should review and refactor validation logic to avoid overlapping or conflicting rules across contexts. Finally, organizations should maintain an incident response plan to quickly address any exploitation attempts.

Description

Laravel Rest Api is an API generator. Prior to version 2.13.0, a validation bypass vulnerability was discovered where multiple validations defined for the same attribute could be silently overridden. Due to how the framework merged validation rules across multiple contexts (such as index, store, and update actions), malicious actors could exploit this behavior by crafting requests that bypass expected validation rules, potentially injecting unexpected or dangerous parameters into the application. This could lead to unauthorized data being accepted or processed by the API, depending on the context in which the validation was bypassed. This issue has been patched in version 2.13.0.

References

Community reviews

Loading reviews…