CVE-2025-58364: OpenPrinting cups · Improper Input Validation
Affects OpenPrinting cupsSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.4.13 when convenient.
Data as of 26 Oct 2026, 08:30 UTC
- EPSS
- 1.1% chance of exploitation in 30 days – higher than 66% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.13
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 11 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade OpenPrinting cups to 2.4.13.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OpenPrinting cups | Affected
| Fixed in
|
AI-suggested
European organizations should promptly upgrade all CUPS installations to version 2.4.13 or later to apply the patch for CVE-2025-58364. Network administrators must audit firewall rules to ensure that IPP ports (typically TCP 631) are not exposed to untrusted networks, especially the public internet. Systems should be segmented to limit printer broadcast traffic to trusted subnets only. Additionally, organizations should verify that related vulnerabilities such as CVE-2024-47176 are also remediated to reduce the risk of remote exploitation. Monitoring network traffic for unusual or malformed IPP requests can help detect exploitation attempts. Employing intrusion detection/prevention systems with signatures for malformed CUPS traffic may provide early warning. Regular vulnerability scanning and asset inventory updates will help identify outdated CUPS versions. Finally, educating IT staff about the importance of patch management and network segmentation in printing infrastructure will reduce exposure.
Description
OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. In versions 2.4.12 and earlier, an unsafe deserialization and validation of printer attributes causes null dereference in the libcups library. This is a remote DoS vulnerability available in local subnet in default configurations. It can cause the cups & cups-browsed to crash, on all the machines in local network who are listening for printers (so by default for all regular linux machines). On systems where the vulnerability CVE-2024-47176 (cups-filters 1.x/cups-browsed 2.x vulnerability) was not fixed, and the firewall on the machine does not reject incoming communication to IPP port, and the machine is set to be available to public internet, attack vector "Network" is possible. The current versions of CUPS and cups-browsed projects have the attack vector "Adjacent" in their default configurations. Version 2.4.13 contains a patch for CVE-2025-58364.
References
- github.com/OpenPrinting/cups/security/advisories/GHSA-7qx3-r744-6qv4 (opens in a new tab)
- github.com/OpenPrinting/cups/commit/e58cba9d6fceed4242980e51dbd1302cf638ab1d (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/09/msg00013.html (opens in a new tab)
- openwall.com/lists/oss-security/2025/09/11/2 (opens in a new tab)