Skip to main content
VulnerabilityPublished

CVE-2025-59542: chamilo-lms · Cross-site Scripting

Affects chamilo-lmsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 1.11.34 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.11.34
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade chamilo-lms and chamilo/chamilo-lms to 1.11.34.

Affected software

ProductAffectedFixed in
chamilochamilo-lmsAffected
  • <1.11.34
Fixed in
  • 1.11.34
GitHubchamilo/chamilo-lmspkg:github/chamilo/chamilo-lmsOther threatsAffected
  • <1.11.34
Fixed in
  • 1.11.34

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Immediately upgrade Chamilo LMS installations to version 1.11.34 or later, where the vulnerability is patched.
  2. Implement strict input validation and output encoding on all user-supplied data fields, especially those accessible by low-privileged users, to prevent injection of executable scripts.
  3. Restrict the ability of low-privileged users to input HTML or JavaScript content in course settings or other fields that render in other users' browsers.
  4. Employ Content Security Policy (CSP) headers to limit the execution of unauthorized scripts in the LMS web application.
  5. Monitor LMS logs for unusual activity or access patterns indicative of exploitation attempts.
  6. Educate administrators and users about the risks of XSS and encourage cautious behavior when interacting with LMS content.
  7. Conduct regular security assessments and penetration testing focused on web application vulnerabilities in the LMS environment.
  8. If immediate patching is not feasible, consider temporarily disabling or restricting the affected course learning path Settings field to prevent malicious input.

Description

Chamilo is a learning management system. Prior to version 1.11.34, there is a stored cross-site scripting (XSS) vulnerability. By injecting malicious JavaScript into the course learning path Settings field, an attacker with a low-privileged account (e.g., trainer) can execute arbitrary JavaScript code in the context of any other user viewing the course information page, including administrators. This allows an attacker to exfiltrate sensitive session cookies or tokens, resulting in account takeover (ATO) of higher-privileged users. This issue has been patched in version 1.11.34.

References

Community reviews

Loading reviews…