Skip to main content
VulnerabilityPublished

CVE-2025-62612: labring FastGPT · Server-Side Request Forgery (SSRF)

Affects labring FastGPTSource CVE Database V5

0

Not known to be exploited · CVSS 6.9 Medium : upgrade to 4.11.1 when convenient.

Data as of 26 Oct 2026, 11:42 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.11.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade labring/FastGPT to 4.11.1.

Affected software

ProductAffectedFixed in
GitHublabring/FastGPTpkg:github/labring/FastGPTOther threatsAffected
  • <4.11.1
Fixed in
  • 4.11.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations using FastGPT should immediately upgrade to version 4.11.1 or later to apply the official patch that enforces security verification on network links in the workflow file reading node. Until the upgrade is applied, organizations should implement network-level controls such as restricting outbound HTTP/HTTPS requests from FastGPT servers to only trusted destinations using firewall rules or proxy whitelisting. Monitoring and logging of outbound requests from FastGPT instances can help detect anomalous or unauthorized requests indicative of SSRF exploitation attempts. Additionally, applying network segmentation to isolate FastGPT servers from sensitive internal services can limit the potential impact of SSRF exploitation. Security teams should conduct internal audits to identify any instances of FastGPT running vulnerable versions and prioritize remediation. Finally, educating developers and administrators on SSRF risks and secure coding practices for AI workflow integrations will help prevent similar issues in the future.

Description

FastGPT is an AI Agent building platform. Prior to version 4.11.1, in the workflow file reading node, the network link is not security-verified, posing a risk of SSRF attacks. This issue has been patched in version 4.11.1.

References

Community reviews

Loading reviews…