Skip to main content
VulnerabilityPublished

CVE-2026-2348: Drupal Quick Edit · Cross-site Scripting

Affects Drupal Quick EditSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.4 Medium : upgrade to 2.0.1 or 1.0.5 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.0.1, 1.0.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Drupal Quick Edit to 2.0.1 or 1.0.5.

Affected software

ProductAffectedFixed in
DrupalQuick EditAffected
  • >=2.0.0 <2.0.1
Fixed in
  • 2.0.1
DrupalQuick EditAffected
  • <1.0.5
Fixed in
  • 1.0.5

AI-suggested

Organizations should immediately upgrade Drupal Quick Edit to versions 1.0.5 or later and 2.0.1 or later once available. In the interim, implement strict input validation and output encoding on all user-supplied data within the Quick Edit context to prevent script injection. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts and reduce the impact of potential XSS attacks. Regularly audit and sanitize all custom code or third-party modules interacting with Quick Edit to ensure they do not introduce similar vulnerabilities. Monitor Drupal security advisories and subscribe to vulnerability feeds for timely updates. Conduct penetration testing focused on XSS vectors in the Quick Edit module and related components. Educate site administrators and developers about secure coding practices, emphasizing the importance of escaping and sanitizing inputs. Consider deploying Web Application Firewalls (WAFs) with rules targeting common XSS payloads as an additional protective layer. Finally, maintain comprehensive logging and monitoring to detect suspicious activities indicative of exploitation attempts.

Description

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Quick Edit allows Cross-Site Scripting (XSS).This issue affects Quick Edit: from 0.0.0 before 1.0.5, from 2.0.0 before 2.0.1.

References

Community reviews

Loading reviews…