CVE-2026-24779: vllm · Server-Side Request Forgery (SSRF)
Affects vllmSource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 0.14.1 soon.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.14.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 27 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade vllm to 0.14.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| vllm-projectvllm | Affected
| Fixed in
|
PyPIvllmpkg:pypi/vllmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch addressing this SSRF vulnerability is available in vLLM version 0.14.1. Users should upgrade to version 0.14.1 or later to remediate the issue. Since this is not a cloud service, remediation requires applying the official fix. Refer to the vendor advisories, including Red Hat's security advisories, for detailed update instructions and confirmation of the fix.
Description
vLLM is an inference and serving engine for large language models (LLMs). Prior to version 0.14.1, a Server-Side Request Forgery (SSRF) vulnerability exists in the `MediaConnector` class within the vLLM project's multimodal feature set. The load_from_url and load_from_url_async methods obtain and process media from URLs provided by users, using different Python parsing libraries when restricting the target host. These two parsing libraries have different interpretations of backslashes, which allows the host name restriction to be bypassed. This allows an attacker to coerce the vLLM server into making arbitrary requests to internal network resources. This vulnerability is particularly critical in containerized environments like `llm-d`, where a compromised vLLM pod could be used to scan the internal network, interact with other pods, and potentially cause denial of service or access sensitive data. For example, an attacker could make the vLLM pod send malicious requests to an internal `llm-d` management endpoint, leading to system instability by falsely reporting metrics like the KV cache state. Version 0.14.1 contains a patch for the issue.
References
- github.com/vllm-project/vllm/security/advisories/GHSA-qh4c-xf7m-gxfc (opens in a new tab)
- github.com/vllm-project/vllm/pull/32746 (opens in a new tab)
- github.com/vllm-project/vllm/commit/f46d576c54fb8aeec5fc70560e850bed38ef17d7 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-24779 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2433624 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-24779.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:3461 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:3462 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:30089 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:30088 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:30087 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:10184 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:42644 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:3782 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:19712 (opens in a new tab)