Skip to main content
VulnerabilityPublished Updated

CVE-2026-2741: vaadin · Path Traversal

Affects vaadinSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 2.3 Low · end of life, no fix coming : replace or isolate vaadin; no fix will be released.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
None coming – the product is end of life
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/S:N/AU:N/R:U/V:D/RE:L/U:Amber

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

No fix will be released: vaadin is end of life. Replace it, or isolate it from untrusted networks until you can.

Affected software

ProductAffectedFixed in
vaadinvaadinAffected
  • >=14.2.0 <=14.14.0
  • >=15.0.0 <=23.6.6
  • >=24.0.0 <=24.9.8
  • >=25.0.0 <=25.0.2
Fixed in–
vaadinflowAffected
  • >=2.2.0 <=2.13.0
  • >=3.0.0 <=23.6.7
  • >=24.0.0 <=24.9.9
Fixed in–
vaadinflowAffected
  • >=25.0.0 <=25.0.3
Fixed in–
Mavencom.vaadin/flowpkg:maven/com.vaadin/flowOther threatsAffected
  • >=14.2.0 <=14.14.0
  • >=23.0.0 <=23.6.6
  • >=24.0.0 <=24.9.8
  • >=25.0.0 <=25.0.2
Fixed in–
Mavenvaadin/com.vaadin:vaadinpkg:maven/vaadin/com.vaadin:vaadinOther threatsAffected
  • >=14.2.0 <=14.14.0
  • >=15.0.0 <=23.6.6
  • >=24.0.0 <=24.9.8
  • >=25.0.0 <=25.0.2
Fixed in–
Mavenvaadin/com.vaadin:flow-serverpkg:maven/vaadin/com.vaadin:flow-serverOther threatsAffected
  • >=2.2.0 <=2.13.0
  • >=3.0.0 <=23.6.7
  • >=24.0.0 <=24.9.9
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Upgrade Vaadin Flow to the patched versions: 14.14.1, 23.6.7, 24.9.9, or 25.0.3 or newer, as applicable.
  2. Use a globally preinstalled Node.js version compatible with the Vaadin version instead of relying on automatic download and extraction during the build process.
  3. Secure the network environment to prevent DNS hijacking and man-in-the-middle attacks, including enforcing DNSSEC, using HTTPS with certificate validation, and employing network segmentation.
  4. Validate and monitor the integrity of third-party mirrors or repositories used for Node.js downloads to prevent supply chain compromise.
  5. Implement strict file system permissions on build servers to limit the impact of arbitrary file writes.
  6. Employ build environment isolation techniques such as containerization or sandboxing to contain potential exploitation.
  7. Regularly audit build logs and extracted files for unexpected changes or suspicious activity.
  8. For unsupported Vaadin versions (10-13, 15-22), upgrade to supported versions to receive security updates. These steps collectively reduce the risk of exploitation by addressing both the vulnerability and the attack vectors enabling it.

Description

Specially crafted ZIP archives can escape the intended extraction directory during Node.js download and extraction in Vaadin 14.2.0 through 14.14.0, 23.0.0 through 23.6.6, 24.0.0 through 24.9.8, and 25.0.0 through 25.0.2. Vaadin’s build process can automatically download and extract Node.js if it is not installed locally. If an attacker can intercept or control this download via DNS hijacking, a MITM attack, a compromised mirror, or a supply chain attack, they can serve a malicious archive containing path traversal sequences that write files outside the intended extraction directory. Users of affected versions should use a globally preinstalled Node.js version compatible with their Vaadin version, or upgrade as follows: 14.2.0-14.14.0 to 14.14.1, 23.0.0-23.6.6 to 23.6.7, 24.0.0-24.9.8 to 24.9.9, and 25.0.0-25.0.2 to 25.0.3 or newer. Please note that Vaadin versions 10-13 and 15-22 are no longer supported and you should update either to the latest 14, 23, 24, 25 version.

References

Community reviews

Loading reviews…