Skip to main content
VulnerabilityPublished

CVE-2026-29178: LemmyNet lemmy · Server-Side Request Forgery (SSRF)

Affects LemmyNet lemmySource CVE Database V5

0
Compare

Public exploit available · CVSS 7.7 High : upgrade to 0.19.16 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.19.16
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade lemmy and github/LemmyNet/lemmy to 0.19.16.

Affected software

ProductAffectedFixed in
LemmyNetlemmyAffected
  • <0.19.16
Fixed in
  • 0.19.16
crates.iogithub/LemmyNet/lemmypkg:cargo/github/LemmyNet/lemmyOther threatsAffected
  • <0.19.16
Fixed in
  • 0.19.16

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade Lemmy to version 0.19.16 or later, where the SSRF vulnerability has been patched. Organizations should prioritize this update to eliminate the unsafe parameter injection. Additionally, administrators should implement network-level controls to restrict outbound HTTP requests from the Lemmy server to only trusted destinations, reducing the impact of potential SSRF exploitation. Employing web application firewalls (WAFs) with rules to detect and block suspicious query parameter patterns targeting the /api/v4/image/ endpoint can provide an additional layer of defense. Monitoring server logs for unusual outbound requests or spikes in traffic to internal services can help detect exploitation attempts. If upgrading immediately is not feasible, temporarily disabling or restricting access to the vulnerable endpoint can reduce exposure. Finally, conducting internal network segmentation and limiting the Lemmy server's access to sensitive internal resources will minimize the potential damage from SSRF attacks.

Description

Lemmy, a link aggregator and forum for the fediverse, is vulnerable to server-side request forgery via a dependency on activitypub_federation, a framework for ActivityPub federation in Rust. Prior to version 0.19.16, the GET /api/v4/image/{filename} endpoint is vulnerable to unauthenticated SSRF through parameter injection in the file_type query parameter. An attacker can inject arbitrary query parameters into the internal request to pict-rs, including the proxy parameter which causes pict-rs to fetch arbitrary URLs. This issue has been patched in version 0.19.16.

References

Community reviews

Loading reviews…