Skip to main content
VulnerabilityPublished

CVE-2026-30947: parse-server · Incorrect Authorization

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 9.5.2-alpha.3 or 8.6.16 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.5.2-alpha.3, 8.6.16
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade parse-server to 9.5.2-alpha.3 or 8.6.16; parse-community/parse-server to 8.6.16.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.5.2-alpha.3
Fixed in
  • 9.5.2-alpha.3
parse-communityparse-serverAffected
  • <8.6.16
Fixed in
  • 8.6.16
npmparse-community/parse-serverpkg:npm/parse-community/parse-serverOther threatsAffected
  • <8.6.16
Fixed in
  • 8.6.16

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately upgrade parse-server deployments to versions 9.5.2-alpha.3 or 8.6.16 or later, where the vulnerability is fixed. Until upgrades are possible, administrators should consider disabling LiveQuery subscriptions or restricting access to trusted networks and clients only. Implement network-level controls such as firewall rules and VPNs to limit exposure of parse-server endpoints. Review and audit existing LiveQuery usage and class-level permission configurations to identify potential data exposure. Employ monitoring and logging to detect unusual subscription activity or unauthorized access attempts. For environments where upgrading is delayed, consider implementing application-layer proxies or middleware that enforce CLP checks on LiveQuery subscriptions as a temporary workaround. Educate development teams about the risks of exposing real-time data without proper authorization enforcement. Finally, maintain an incident response plan to quickly address any detected data leaks or unauthorized access stemming from this vulnerability.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.3 and 8.6.16, class-level permissions (CLP) are not enforced for LiveQuery subscriptions. An unauthenticated or unauthorized client can subscribe to any LiveQuery-enabled class and receive real-time events for all objects, regardless of CLP restrictions. All Parse Server deployments that use LiveQuery with class-level permissions are affected. Data intended to be restricted by CLP is leaked to unauthorized subscribers in real time. This vulnerability is fixed in 9.5.2-alpha.3 and 8.6.16.

References

Community reviews

Loading reviews…