CVE-2026-45087: hahwul dalfox · External Control of System or Configuration Setting
Affects hahwul dalfoxSource CVE Database V5
Public exploit available (Metasploit) · CVSS 10.0 Critical : upgrade to 2.13.0 as a priority.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 8.7% chance of exploitation in 30 days – higher than 95% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.13.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade dalfox and hahwul/dalfox to 2.13.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| hahwuldalfox | Affected
| Fixed in
|
GitHubhahwul/dalfoxpkg:github/hahwul/dalfoxOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade dalfox to version 2.13.0 or later, where this vulnerability is fixed. Until upgrading, do not run dalfox in REST API server mode without specifying an API key and binding to a restricted interface. Restrict network access to the server port 6664 to trusted users only. Patch status is confirmed fixed in version 2.13.0.
Description
CVE-2026-45087 is a critical vulnerability in hahwul dalfox versions prior to 2.13.0. When running dalfox in REST API server mode, it binds to all interfaces on port 6664 by default without requiring an API key. The server deserializes attacker-controlled JSON input for scan options, including fields that allow arbitrary shell command execution on the host when a scan finding is triggered. This vulnerability allows unauthenticated remote attackers to execute arbitrary commands. The issue is fixed in version 2.13.0.