Skip to main content
VulnerabilityPublished

CVE-2026-107651: eog security update

Affects eogSource GCVE Database

0
Compare
Authoritative record:CVE-2026-107651· Medium 5.5

Not known to be exploited · CVSS 5.5 Medium : upgrade to 44.3-2.oe2403sp1 when convenient.

Data as of 29 Oct 2026, 11:04 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 44.3-2.oe2403sp1
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade eog to 44.3-2.oe2403sp1.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP1eogpkg:rpm/openEuler/eog&distro=openEuler-24.03-LTS-SP1Other threatsAffected
  • <44.3-2.oe2403sp1
Fixed in
  • 44.3-2.oe2403sp1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing this vulnerability is available in eog version 44.3-2.oe2403sp1. Users and administrators should apply this update to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.

Description

A heap-based buffer overflow vulnerability exists in the PNG metadata reader of Eye of GNOME (eog) due to improper state handling when parsing split metadata chunks. This flaw could be triggered by a user opening a specially crafted PNG file, potentially causing a denial of service via application crash or arbitrary code execution. The vulnerability affects versions of eog prior to 44.3-2.oe2403sp1. A security update fixing this issue is available.

References

Community reviews

Loading reviews…