Skip to main content
VulnerabilityPublished Updated

CVE-2025-48386: Git Allows a Buffer Overflow

Affects gitSource GCVE Database

0
Compare
Authoritative record:CVE-2025-48386· Medium 6.3

Not known to be exploited · CVSS 6.3 Medium : upgrade to 2.50.1 when convenient.

Data as of 4 Nov 2026, 18:27 UTC

CVSS 3.1 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.16.3
Patch
Available – fixed in 2.50.1
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade git to 2.50.1.

Affected software

ProductAffectedFixed in
Bitnamigitpkg:bitnami/gitOther threatsAffected
  • <2.50.1
Fixed in
  • 2.50.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official fix by upgrading Git to version 2.50.1 or later, where this buffer overflow vulnerability has been resolved.

Description

Git's wincred credential helper contains a buffer overflow vulnerability due to improper bounds checking when appending to a static buffer. This flaw allows potential memory corruption. The issue is fixed in Git version 2.50.1 and later.

References

Community reviews

Loading reviews…