Skip to main content
VulnerabilityPublished Updated

CVE-2026-100408: Git for Windows is the Windows port of Git

Affects gitSource GCVE Database

0
Compare
Authoritative record:CVE-2026-100408· Medium 4.4

Not known to be exploited · CVSS 4.4 Medium · fixed in 2.55.0 : update git when convenient.

Data as of 6 Nov 2026, 05:34 UTC

CVSS 3.1 base score
4.4Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.14.4
Patch
Available – fixed in 2.55.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10gitpkg:deb/ubuntu/git?arch=source&distro=stonkingOther threatsAffected
  • =1:2.53.0-1ubuntu1
  • =1:2.55.0-1ubuntu1
  • =1:2.55.0-1ubuntu1.1
Fixed in–
Ubuntu 26.04 LTSgitpkg:deb/ubuntu/git?arch=source&distro=resoluteOther threatsAffected
  • =1:2.51.0-1ubuntu1
  • =1:2.53.0-1ubuntu1
  • =1:2.53.0-1ubuntu1.1
Fixed in–
Ubuntu 24.04 LTSgitpkg:deb/ubuntu/git?arch=source&distro=nobleOther threatsAffected
  • 1:2.40.1-1ubuntu1 – 1:2.43.0-1ubuntu7.4
9 affected builds
Fixed in–
Ubuntu 22.04 LTSgitpkg:deb/ubuntu/git?arch=source&distro=jammyOther threatsAffected
  • 1:2.32.0-1ubuntu1 – 1:2.34.1-1ubuntu1.18
19 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSgitpkg:deb/ubuntu/git?arch=source&distro=esm-infra/focalOther threatsAffected
  • 1:2.20.1-2ubuntu1 – 1:2.25.1-1ubuntu3.14+esm6
26 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSgitpkg:deb/ubuntu/git?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 1:2.14.1-1ubuntu4 – 1:2.17.1-1ubuntu0.18+esm8
26 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Git for Windows to version 2.55.0.windows.3 or later where this issue is fixed. Until then, avoid using git-credential-wincred erase operations that include a password field. No other mitigations are specified.

Description

A heap corruption vulnerability exists in Git for Windows versions from 2.43.0.windows.1 up to 2.55.0.windows.3 in the git-credential-wincred helper when erasing credentials with a password field. This can cause the helper to terminate with a heap corruption error and fail to delete the credential, although the operation may appear successful. The issue is fixed in version 2.55.0.windows.3.

References

Community reviews

Loading reviews…