CVE-2026-67338: JupyterLab before 4.5.9 contains a stored cross-site scripting vulnerability in the Extension Manager that fails to validate URI protocols in
Affects jupyterlabSource GCVE Database
Not known to be exploited · CVSS 6.1 Medium : upgrade to 4.5.9 when convenient.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.5.9
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade jupyterlab to 4.5.9.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPIjupyterlabpkg:pypi/jupyterlabOther threats | Affected
| Fixed in
|
Ubuntu 26.10jupyterlabpkg:deb/ubuntu/jupyterlab?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSjupyterlabpkg:deb/ubuntu/jupyterlab?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version, 4.5.9, is available that addresses this vulnerability. Users should upgrade to JupyterLab version 4.5.9 or later to remediate this issue. No additional mitigation steps are indicated beyond applying the official fix.
Description
JupyterLab versions prior to 4.5.9 contain a stored cross-site scripting (XSS) vulnerability in the Extension Manager. This flaw arises because the Extension Manager does not properly validate URI protocols in package metadata URLs. Malicious PyPI packages can exploit this by including javascript: URLs in their metadata, which execute arbitrary JavaScript in the context of the JupyterLab origin when users click on the extension name.
References
- github.com/jupyterlab/jupyterlab/security/advisories/GHSA-vmhf-c436-hxj4 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-67338 (opens in a new tab)
- github.com/jupyterlab/jupyterlab/commit/4e61e07d0a91145b53fbf96ac74b0387f6bc51f6 (opens in a new tab)
- github.com/jupyterlab/jupyterlab/commit/d5d961f6e10a6442dddbf94d9a976b3897055a12 (opens in a new tab)
- vulncheck.com/advisories/jupyterlab-before-stored-xss-via-extension-manager (opens in a new tab)
- ubuntu.com/security/CVE-2026-67338 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-67338 (opens in a new tab)