Skip to main content
VulnerabilityPublished Updated

CVE-2026-73627: JupyterLab PluginManager lock-rule enforcement bypass

Affects jupyterlabSource GCVE Database

0
Compare

Not known to be exploited · CVSS 6.0 Medium : upgrade to 4.6.2 when convenient.

Data as of 31 Oct 2026, 16:54 UTC

CVSS 4.0 base score
6.0Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.6.2
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade jupyterlab to 4.6.2.

Affected software

ProductAffectedFixed in
Homebrewjupyterlabpkg:brew/jupyterlabOther threatsAffected
  • >=4.1.0 <4.6.2
Fixed in
  • 4.6.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading to JupyterLab version 4.6.2 or 4.5.10, which contain the fix for this vulnerability. Users of dependent applications like Notebook v7+ should also update their jupyterlab package. As a workaround, manually lock all plugins that require restriction using core plugin identifiers and those listed in the Plugin Manager documentation.

Description

JupyterLab versions from 4.1.0 up to but not including 4.6.2 have a vulnerability in the plugin manager that allows authenticated users to bypass administrator-enforced plugin lock rules via direct API requests. This bypass affects child plugins of multi-plugin extensions and scenarios where administrators issued a 'lock all' command. The vulnerability can impact data integrity and circumvent restrictions implemented through locked plugins. Fixed in JupyterLab 4.6.2 and 4.5.10.

References

Community reviews

Loading reviews…