Skip to main content
VulnerabilityPublished Updated

CVE-2026-73417: JupyterLab · Cross-site scripting (XSS) via crafted settings file (`overrides.json`)

Affects jupyterlabSource GCVE Database

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 4.6.2 soon.

Data as of 31 Oct 2026, 16:54 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.6.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:L/SC:N/SI:N/SA:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade jupyterlab to 4.6.2.

Affected software

ProductAffectedFixed in
Homebrewjupyterlabpkg:brew/jupyterlabOther threatsAffected
  • >=3.3.0 <4.6.2
Fixed in
  • 4.6.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading JupyterLab to version 4.6.2 or later. There are no effective workarounds. Administrators should treat settings files as potentially executable configuration, establishing trusted processes for distributing configuration files rather than relying on ad-hoc imports. On multi-tenant or shared file systems, restrict write permissions on JupyterLab settings directories to prevent unauthorized placement of overrides.json files that are automatically applied.

Description

JupyterLab versions 3.3.0 up to but not including 4.6.2 contain a cross-site scripting (XSS) vulnerability via crafted settings files named overrides.json. This file can be imported by users or automatically loaded from configuration directories. The vulnerability allows embedded code in the settings file to execute with the user's privileges, potentially reading or modifying notebooks and running code on the notebook server and connected kernels. The issue arises because certain notebook display settings were not properly validated before application. Patches are available in versions 4.6.2 and later.

References

Community reviews

Loading reviews…