CVE-2026-73415: JupyterLab · Image viewer allows XSS when opening malicious image in new browser tab
Affects jupyterlabSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 4.6.2 soon.
Data as of 31 Oct 2026, 17:05 UTC
- Patch
- Available – fixed in 4.6.2
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:A/VC:H/VI:H/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade jupyterlab to 4.6.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewjupyterlabpkg:brew/jupyterlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official patches by upgrading JupyterLab to version 4.6.2 or later, or to 4.5.10 if on the 4.5 branch. As a temporary workaround, disable the image viewer plugin using the command `jupyter labextension disable @jupyterlab/imageviewer-extension:plugin`. Confirm the plugin is disabled with `jupyter labextension list`. No other actions are specifically recommended by the vendor advisory.
Description
JupyterLab's image viewer contains a cross-site scripting (XSS) vulnerability when opening a specially crafted image file and then opening it in a new browser tab. This vulnerability can lead to remote code execution on the JupyterLab server. Versions prior to 4.6.2 are affected. The issue is patched in versions 4.6.2 and 4.5.10. As a workaround, disabling the image viewer plugin can mitigate the risk.
References
- github.com/jupyterlab/jupyterlab/security/advisories/GHSA-gx64-gj6p-pc4c (opens in a new tab)
- github.com/jupyterlab/jupyterlab/pull/19184 (opens in a new tab)
- github.com/jupyterlab/jupyterlab/pull/19185 (opens in a new tab)
- github.com/jupyterlab/jupyterlab/pull/19186 (opens in a new tab)
- github.com/jupyterlab/jupyterlab/commit/be9303f5bcd5308eaeae953c5a3c903046682c2c (opens in a new tab)
- github.com/jupyterlab/jupyterlab/commit/f1beab4a2027af4719d6edc07d52d6cf5a39a432 (opens in a new tab)
- github.com/jupyterlab/jupyterlab (opens in a new tab)
- github.com/jupyterlab/jupyterlab/releases/tag/v4.5.10 (opens in a new tab)
- github.com/jupyterlab/jupyterlab/releases/tag/v4.6.2 (opens in a new tab)