Skip to main content
VulnerabilityPublished Updated

CVE-2026-67338: JupyterLab · Stored XSS in extension manager through package metadata unsanitized URI protocol

Affects jupyterlabSource GCVE Database

0
Compare

Not known to be exploited · CVSS 5.1 Medium : upgrade to 4.5.9 when convenient.

Data as of 31 Oct 2026, 17:05 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.5.9
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade jupyterlab to 4.5.9.

Affected software

ProductAffectedFixed in
Homebrewjupyterlabpkg:brew/jupyterlabOther threatsAffected
  • >=1.2.0 <4.5.9
Fixed in
  • 4.5.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is patched in JupyterLab version 4.5.9. Users and administrators should upgrade to version 4.5.9 or later to remediate this issue. No other mitigation is required if the patch is applied.

Description

JupyterLab versions from 1.2.0 up to but not including 4.5.9 contain a stored cross-site scripting (XSS) vulnerability in the Extension Manager. A malicious PyPI package can include a 'javascript:' URL in its metadata, which JupyterLab renders as a clickable homepage link without validating the URL protocol. When a user clicks this link, attacker-controlled JavaScript executes in the JupyterLab origin. This vulnerability requires the Extension Manager to be enabled with the default PyPI source and the malicious package to appear in the user's extension list.

References

Community reviews

Loading reviews…