CVE-2026-73416: JupyterLab · PyPI extension blocklist package-name canonicalization bypass
Affects jupyterlabSource GCVE Database
Not known to be exploited · CVSS 6.1 Medium : upgrade to 4.6.2 when convenient.
Data as of 31 Oct 2026, 16:54 UTC
- Patch
- Available – fixed in 4.6.2
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade jupyterlab to 4.6.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewjupyterlabpkg:brew/jupyterlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading to JupyterLab version 4.6.2 or later. Users of dependent applications like Notebook v7+ should also update the jupyterlab package. Deployments without custom allow/block lists require no action. To disable programmatic extension installation entirely, switch to the read-only extension manager by setting '--LabApp.extension_manager=readonly' or 'c.LabApp.extension_manager = "readonly"'.
Description
JupyterLab versions from 4.5.0 up to but not including 4.6.2 have a vulnerability in the PyPI extension manager's blocklist enforcement. Authenticated users can bypass package-name blocking by using PyPI-equivalent spellings, allowing installation of otherwise blocked extensions. This can impact the integrity and availability of the single-user server instance, especially in deployments with custom allow/block lists and restricted kernel access. The issue is fixed in version 4.6.2.
References
- github.com/jupyterlab/jupyterlab/security/advisories/GHSA-89vp-jrxv-24w8 (opens in a new tab)
- github.com/jupyterlab/jupyterlab/pull/19184 (opens in a new tab)
- github.com/jupyterlab/jupyterlab/pull/19185 (opens in a new tab)
- github.com/jupyterlab/jupyterlab/pull/19186 (opens in a new tab)
- github.com/jupyterlab/jupyterlab/commit/be9303f5bcd5308eaeae953c5a3c903046682c2c (opens in a new tab)
- github.com/jupyterlab/jupyterlab/commit/f1beab4a2027af4719d6edc07d52d6cf5a39a432 (opens in a new tab)
- github.com/jupyterlab/jupyterlab (opens in a new tab)
- github.com/jupyterlab/jupyterlab/releases/tag/v4.5.10 (opens in a new tab)
- github.com/jupyterlab/jupyterlab/releases/tag/v4.6.2 (opens in a new tab)