Skip to main content
CVE-2026-73626VulnerabilityPublished Updated

JupyterLab: Allowlist/blocklist check

Affects jupyterlabSource GCVE Database

0
Compare

Not known to be exploited · CVSS 0.0 Low : upgrade to 4.6.2 when convenient.

Data as of 31 Oct 2026, 16:54 UTC

CVSS 3.1 base score
0.0Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.6.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade jupyterlab to 4.6.2.

Affected software

ProductAffectedFixed in
Homebrewjupyterlabpkg:brew/jupyterlabOther threatsAffected
  • >=1.2.0 <4.6.2
Fixed in
  • 4.6.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in JupyterLab versions 4.6.2 and 4.5.10. Users should update to these versions or later. No action is required for deployments using only the HTTP API or Extension Manager UI for extension management, as these paths enforce restrictions correctly. Deployments wanting to disable programmatic extension installation entirely can configure the extension manager to read-only mode using the --LabApp.extension_manager=readonly command-line option or the c.LabApp.extension_manager = 'readonly' configuration traitlet.

Description

A missing await in JupyterLab's PyPIExtensionManager.install() method caused the allowlist/blocklist check to not be enforced for direct callers. This vulnerability affects only custom extensions or downstream integrations that call install() directly with untrusted input, combined with an allowlist/blocklist configured and the default PyPI Extension Manager enabled while kernels and terminals are disabled or remote. Stock JupyterLab HTTP API and Extension Manager UI are not affected. The issue is fixed in JupyterLab versions 4.6.2 and later.

References

Community reviews

Loading reviews…