Skip to main content
VulnerabilityPublished Updated

Nx: OS command injection via git revisions and remote refs

Affects nxSource GCVE Database

0

CVSS 8.5 High : upgrade to 23.1.1 soon.

Data as of 30 Oct 2026, 08:14 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 23.1.1
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

What to do

Upgrade nx to 23.1.1.

Affected software

ProductAffectedFixed in
Homebrewnxpkg:brew/nxOther threatsAffected
  • >=21.0.4 <23.1.1
Fixed in
  • 23.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Nx to version 22.7.8 or later in the 22.x line, or 23.1.1 or later in the 23.x line. The fix is a drop-in upgrade requiring no configuration changes. If upgrading is not possible, treat nx.json files from untrusted sources as executable content, avoid running 'nx affected' commands against unreviewed pull requests, and do not run 'nx import' against untrusted repositories.

Description

Nx versions from 14.0.0 up to but not including 22.7.8, and from 23.0.0 up to but not including 23.1.1, contain a command injection vulnerability. This occurs because Nx builds shell command strings with untrusted git revision or branch name values interpolated directly, allowing an attacker controlling repository content to execute arbitrary commands on machines running Nx commands like 'nx affected' or 'nx import'. The vulnerability is particularly serious in CI environments where these commands run automatically. Fixed in versions 22.7.8 and 23.1.1.

References

Community reviews

Loading reviews…