CVE-2026-54753: `nx graph` dev server permissive CORS policy
Affects nxSource GCVE Database
Not known to be exploited · CVSS 5.9 Medium : upgrade to 22.7.2 when convenient.
Data as of 30 Oct 2026, 08:15 UTC
- Patch
- Available – fixed in 22.7.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade nx to 22.7.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewnxpkg:brew/nxOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in `nx` version 22.7.2 and later (including 23.0.0 and above). Users should upgrade to these versions to eliminate the permissive CORS header and prevent cross-origin data leaks. The 21.x line is unpatched and should be upgraded. No additional mitigation is required beyond applying the official fix.
Description
The `nx graph` development server had a permissive CORS policy that allowed any website to read responses from the local server, including sensitive project graph data and the output of a `/help` endpoint that executes configured help commands. This could lead to cross-origin information disclosure. Exploitation requires the developer to be running the vulnerable `nx graph` server and to visit a malicious website. Arbitrary command execution is only possible if a malicious help command is already configured in the workspace, which requires prior compromise. The issue affects versions from 17.0.4 up to but not including 22.7.2 and certain beta versions before 23.0.0-beta.2. A fix is available starting with version 22.7.2.
References
- github.com/nrwl/nx/security/advisories/GHSA-g2r8-wvmj-jf5w (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-54753 (opens in a new tab)
- github.com/nrwl/nx/pull/35494 (opens in a new tab)
- github.com/nrwl/nx/commit/7620c1ffe598086ce5e66457c7e6e38799bb499d (opens in a new tab)
- github.com/nrwl/nx/commit/e59122c5569cf201561b9995ce4e34a304f4fb03 (opens in a new tab)
- github.com/nrwl/nx (opens in a new tab)
- github.com/nrwl/nx/releases/tag/22.7.2 (opens in a new tab)