CVE-2026-71476: Nx · Zip-Slip in the self-hosted remote cache
Affects nxSource GCVE Database
Not known to be exploited · CVSS 8.7 High : upgrade to 23.0.2 soon.
Data as of 30 Oct 2026, 08:15 UTC
- Patch
- Available – fixed in 23.0.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade nx to 23.0.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewnxpkg:brew/nxOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Nx to version 22.7.7 or 23.0.2 or later to apply the patched extractor that prevents path traversal during cache artifact extraction. No configuration changes are required. For users of deprecated self-hosted cache packages (@nx/s3-cache, @nx/gcs-cache, @nx/azure-cache, @nx/shared-fs-cache and predecessors), migrate off these packages to Nx Cloud or the self-hosted OpenAPI/HTTP remote cache as they are not patched and remain vulnerable.
Description
Nx's self-hosted HTTP remote cache has a Zip-Slip vulnerability (CVE-2026-71476) that allows a malicious or MITM remote cache server to craft tar archives that write files outside the intended cache directory, potentially leading to remote code execution. This affects Nx versions from 21.0.4 up to but not including 23.0.2. The default local cache and Nx Cloud are not affected. The vulnerability is fixed in Nx 23.0.2. Deprecated self-hosted cache packages remain vulnerable and should be migrated off.
References
- github.com/nrwl/nx/security/advisories/GHSA-vp3h-ghgh-jr7g (opens in a new tab)
- github.com/nrwl/nx/pull/36116 (opens in a new tab)
- github.com/nrwl/nx/commit/2b20c2da39d263c32ae05767577589481a309fee (opens in a new tab)
- github.com/nrwl/nx/commit/a82807621e4176e37909d2c1afede661b45cc30 (opens in a new tab)
- github.com/nrwl/nx/commit/ad296578fe980a4aad66f8af0add21f6ddf907d9 (opens in a new tab)
- github.com/nrwl/nx (opens in a new tab)