CVE-2026-104853: Path traversal in nx migrate package-migrations extraction
Affects nxSource GCVE Database
Not known to be exploited · CVSS 5.8 Medium : upgrade to 23.2.1 when convenient.
Data as of 30 Oct 2026, 08:15 UTC
- Patch
- Available – fixed in 23.2.1
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:L/VI:H/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade nx to 23.2.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewnxpkg:brew/nxOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you run `nx migrate` normally, no action is required because it fetches and runs the latest patched nx version. Upgrade to nx version 22.7.10 or later (22.x line) or 23.2.1 or later (23.x line) if you bypass the default hand-off to the latest nx version by setting environment variables such as `NX_USE_LOCAL` or `NX_MIGRATE_USE_LOCAL`, pinning `NX_MIGRATE_CLI_VERSION` to a vulnerable version, resuming with `--run-id`, or if fallback to the local nx occurs. Avoid running `nx migrate` against untrusted packages or package groups. The fix is a drop-in and does not require configuration changes.
Description
CVE-2026-104853 is a path traversal vulnerability in the nx tool's migrate command. It occurs because the migration file path from a package manifest is not validated, allowing extraction outside the intended temporary directory. This can lead to attacker-controlled file writes or truncation of files writable by the user, potentially enabling code execution if critical files are overwritten. The vulnerability affects nx versions from 13.10.0 up to but not including 22.7.10, and from 23.0.0 up to but not including 23.2.1. Most users running nx migrate normally are not exposed because the tool fetches and runs the latest patched nx version. Exposure occurs only if the local vulnerable nx version is forced to run. A fix is available in versions 22.7.10 and 23.2.1. No known exploitation in the wild has been reported.
References
- github.com/nrwl/nx/security/advisories/GHSA-hrvq-x7jp-36xv (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-104853 (opens in a new tab)
- github.com/nrwl/nx/pull/36887 (opens in a new tab)
- github.com/nrwl/nx/commit/38cd82a0c05e8212e538bdb87ccb198d6504e58f (opens in a new tab)
- github.com/nrwl/nx/commit/95474ab457e8e1dbdbefad29040c166105a8fb90 (opens in a new tab)
- github.com/nrwl/nx/commit/de37c5ebd1852fac700d70726326236ac398af3f (opens in a new tab)
- github.com/nrwl/nx (opens in a new tab)
- github.com/nrwl/nx/releases/tag/22.7.10 (opens in a new tab)
- github.com/nrwl/nx/releases/tag/23.2.1 (opens in a new tab)