Skip to main content
VulnerabilityPublished Updated

CVE-2026-104854: Nx daemon and plugin worker sockets are accessible to other local users

Affects nxSource GCVE Database

0
Compare
Authoritative record:CVE-2026-104854· High 8.5

Not known to be exploited · CVSS 8.5 High : upgrade to 23.1.2 soon.

Data as of 30 Oct 2026, 08:15 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 23.1.2
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade nx to 23.1.2.

Affected software

ProductAffectedFixed in
Homebrewnxpkg:brew/nxOther threatsAffected
  • >=21.0.4 <23.1.2
Fixed in
  • 23.1.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Nx to version 22.7.9 or 23.1.2 or later. After upgrading on shared machines, run 'nx reset' to remove any sockets and directories created by older versions. If upgrading is not possible, set the NX_SOCKET_DIR environment variable to a directory owned by the user with mode 0700 and disable the daemon by setting NX_DAEMON=false. Note that disabling the daemon alone does not fully mitigate the risk due to accessible plugin worker sockets.

Description

Nx daemon and plugin worker sockets are created in a shared temporary directory with default permissions, allowing any local user on the same machine to connect to them. This can lead to code execution inside the daemon process by sending a specially crafted request. The vulnerability affects multi-user environments such as shared build servers or containers with multiple user accounts. Single-user machines are not affected. Versions from 14.6.0 up to but not including 22.7.9, and from 23.0.0 up to but not including 23.1.2 are vulnerable. Upgrading to 22.7.9 or 23.1.2 or later mitigates the issue.

References

Community reviews

Loading reviews…