Prior to 0.32.0, vllm/tokenizers/hf.py computes max_token_id with an off-by-one upper bound, allowing a pre-tokenized
Affects vllmSource GCVE Database
Not known to be exploited · CVSS 6.5 Medium : upgrade to 0.32.0 when convenient.
Data as of 29 Oct 2026, 14:41 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 6.5 |
|---|
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.32.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade vllm to 0.32.0.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPIvllmpkg:pypi/vllmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to vLLM version 0.32.0 or later, where this off-by-one error and related assertion failure have been fixed. The vendor has provided an official patch and advisory. No other mitigation is required once the update is applied.
Description
vLLM versions prior to 0.32.0 contain an off-by-one error in the computation of max_token_id in the hf.py tokenizer module. This flaw allows a pre-tokenized prompt ID equal to the vocabulary size to bypass validation. Under specific conditions involving tensor-parallel size and vocabulary size, this leads to a CUDA device-side assertion failure that terminates the engine. The issue is fixed in version 0.32.0.
References
- github.com/vllm-project/vllm/releases/tag/v0.32.0 (opens in a new tab)
- github.com/vllm-project/vllm/commit/37cecc8141e2dcba9dd534897a164d4baaf27229 (opens in a new tab)
- github.com/vllm-project/vllm/pull/59491 (opens in a new tab)
- github.com/vllm-project/vllm/security/advisories/GHSA-q97c-p368-75c4 (opens in a new tab)