Skip to main content
VulnerabilityPublished

prestashop/ps_checkout · Ps checkout: ps_checkout allows unauthorized method invocation through unvalidated parameter

Affects prestashop/ps_checkoutSource GCVE Database

0

CVSS 6.9 Medium : upgrade to 5.3.0 when convenient.

Data as of 27 Oct 2026, 00:30 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.3.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U

What to do

Upgrade prestashop/ps_checkout to 5.3.0.

Affected software

ProductAffectedFixed in
Packagistprestashop/ps_checkoutAffected
  • <5.3.0
Fixed in
  • 5.3.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade the ps_checkout module to version 5.3.0 or later for your respective PrestaShop version (1.7, 8, or 9). This update contains the official fix for the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

The ps_checkout component of PrestaShop versions prior to 5.3.0 contains a vulnerability where an unvalidated parameter allows unauthorized method invocation. This issue has been patched in version 5.3.0 for PrestaShop 1.7, 8, and 9. The vulnerability has a medium severity rating with a CVSS score of 6.9.

References

Community reviews

Loading reviews…