Skip to main content
CVE-2026-37457VulnerabilityPublished Updated

Quagga: An off-by-one out-of-bounds write vulnerability

Affects quaggaSource GCVE Database

0
Compare
Authoritative record:CVE-2026-37457· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 8.1-1ubuntu1.16 : patch quagga soon.

Data as of 5 Nov 2026, 22:37 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 8.1-1ubuntu1.16, 8.4.4-1.1ubuntu6.7, 10.4.1-3ubuntu1.4 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=resoluteOther threatsAffected
  • <10.5.1-1ubuntu4.1
Fixed in
  • 10.5.1-1ubuntu4.1
Ubuntu 25.10frrpkg:deb/ubuntu/frr?arch=source&distro=questingOther threatsAffected
  • <10.4.1-3ubuntu1.4
Fixed in
  • 10.4.1-3ubuntu1.4
Ubuntu 24.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=nobleOther threatsAffected
  • <8.4.4-1.1ubuntu6.7
Fixed in
  • 8.4.4-1.1ubuntu6.7
Ubuntu 22.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=jammyOther threatsAffected
  • <8.1-1ubuntu1.16
Fixed in
  • 8.1-1ubuntu1.16
Ubuntu 20.04 LTSquaggapkg:deb/ubuntu/quagga?arch=source&distro=focalOther threatsAffected
  • 1.2.4-4build1 – 1.2.4-4ubuntu0.5
4 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=esm-apps/focalOther threatsAffected
  • 6.0.2-2build2 – 7.2.1-1ubuntu0.2+esm5
11 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and can be applied by updating to the patched package versions: 8.1-1ubuntu1.16, 8.4.4-1.1ubuntu6.7, 10.4.1-3ubuntu1.4, or 10.5.1-1ubuntu4.1 as per the Ubuntu security notice USN-8376-1. Applying these updates will remediate the vulnerability and prevent denial of service attacks exploiting this flaw.

Description

An off-by-one out-of-bounds write vulnerability exists in the bgp_flowspec_op_decode() function of FRRouting (FRR) stable/10.0. This flaw allows attackers to cause a denial of service (DoS) by supplying a crafted FlowSpec component. The issue affects multiple versions of the Quagga package as used in Ubuntu distributions. Fixed versions are available and updating to these versions mitigates the vulnerability.

References

Community reviews

Loading reviews…