Skip to main content
CVE-2026-28532VulnerabilityPublished Updated

Quagga: FRRouting before 10.5.3 contains an integer overflow vulnerability in seven OSPF Traffic Engineering and

Affects quaggaSource GCVE Database

0
Compare
Authoritative record:CVE-2026-28532· Medium 6.0

Not known to be exploited · CVSS 6.0 Medium · fixed in 8.1-1ubuntu1.16 : update quagga when convenient.

Data as of 5 Nov 2026, 22:38 UTC

CVSS 4.0 base score
6.0Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 8.1-1ubuntu1.16, 8.4.4-1.1ubuntu6.7, 10.4.1-3ubuntu1.4 +1
CVSS:4.0/AV:A/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=resoluteOther threatsAffected
  • <10.5.1-1ubuntu4.1
Fixed in
  • 10.5.1-1ubuntu4.1
Ubuntu 25.10frrpkg:deb/ubuntu/frr?arch=source&distro=questingOther threatsAffected
  • <10.4.1-3ubuntu1.4
Fixed in
  • 10.4.1-3ubuntu1.4
Ubuntu 24.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=nobleOther threatsAffected
  • <8.4.4-1.1ubuntu6.7
Fixed in
  • 8.4.4-1.1ubuntu6.7
Ubuntu 22.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=jammyOther threatsAffected
  • <8.1-1ubuntu1.16
Fixed in
  • 8.1-1ubuntu1.16
Ubuntu 20.04 LTSquaggapkg:deb/ubuntu/quagga?arch=source&distro=focalOther threatsAffected
  • 1.2.4-4build1 – 1.2.4-4ubuntu0.5
4 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=esm-apps/focalOther threatsAffected
  • 6.0.2-2build2 – 7.2.1-1ubuntu0.2+esm5
11 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and should be applied by updating FRRouting to the patched versions: 8.1-1ubuntu1.16, 8.4.4-1.1ubuntu6.7, 10.4.1-3ubuntu1.4, or 10.5.1-1ubuntu4.1 depending on your Ubuntu release. The vendor advisory (Ubuntu Security Notice USN-8376-1) recommends applying standard system updates to obtain these fixes. No additional mitigation is required beyond applying the official patches.

Description

FRRouting (FRR) versions before 10.5.3 contain an integer overflow vulnerability in the OSPF Traffic Engineering and Segment Routing TLV parser functions. This flaw arises from a uint16_t accumulator truncating uint32_t values, causing unchecked pointer advancement and out-of-bounds memory reads. An attacker with an established OSPF adjacency can send crafted LS Update packets with malicious Type 10 or Type 11 Opaque LSAs to trigger crashes, resulting in denial of service across affected routers in the OSPF area or autonomous system. Fixes are available in FRR versions 8.1-1ubuntu1.16, 8.4.4-1.1ubuntu6.7, 10.4.1-3ubuntu1.4, and 10.5.1-1ubuntu4.1.

References

Community reviews

Loading reviews…