Skip to main content
CVE-2025-61107VulnerabilityPublished Updated

Quagga: FRRouting/frr from v4.0 through v10.4.1 was discovered to contain a NULL pointer dereference via the

Affects quaggaSource GCVE Database

0
Compare
Authoritative record:CVE-2025-61107· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 8.1-1ubuntu1.14 : patch quagga soon.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.1-1ubuntu1.14, 8.4.4-1.1ubuntu6.5, 10.4.1-3ubuntu1.1 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=resoluteOther threatsAffected
  • <10.5.1-1ubuntu2
Fixed in
  • 10.5.1-1ubuntu2
Ubuntu 25.10frrpkg:deb/ubuntu/frr?arch=source&distro=questingOther threatsAffected
  • <10.4.1-3ubuntu1.1
Fixed in
  • 10.4.1-3ubuntu1.1
Ubuntu 24.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=nobleOther threatsAffected
  • <8.4.4-1.1ubuntu6.5
Fixed in
  • 8.4.4-1.1ubuntu6.5
Ubuntu 22.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=jammyOther threatsAffected
  • <8.1-1ubuntu1.14
Fixed in
  • 8.1-1ubuntu1.14
Ubuntu 20.04 LTSquaggapkg:deb/ubuntu/quagga?arch=source&distro=focalOther threatsAffected
  • 1.2.4-4build1 – 1.2.4-4ubuntu0.5
4 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=esm-apps/focalOther threatsAffected
  • 6.0.2-2build2 – 7.2.1-1ubuntu0.2+esm5
11 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and should be applied by updating to the patched package versions provided by Ubuntu: 8.1-1ubuntu1.14, 8.4.4-1.1ubuntu6.5, 10.4.1-3ubuntu1.1, or 10.5.1-1ubuntu2 depending on your Ubuntu release. A standard system update will apply the necessary changes. No additional mitigation steps are required beyond applying these official updates.

Description

FRRouting (FRR) versions from 4.0 through 10.4.1 contain a vulnerability in the show_vty_ext_pref_pref_sid function in ospf_ext.c that allows remote attackers to cause a denial of service (DoS) via a crafted LSA Update packet. This is due to a NULL pointer dereference. The issue affects multiple Ubuntu package versions and has been assigned CVE-2025-61107 with a CVSS 3.1 score of 7.5 (high severity).

References

Community reviews

Loading reviews…