Skip to main content
CVE-2026-37458VulnerabilityPublished Updated

Quagga: Missing input validation

Affects quaggaSource GCVE Database

0
Compare
Authoritative record:CVE-2026-37458· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium · fixed in 8.1-1ubuntu1.16 : update quagga when convenient.

Data as of 5 Nov 2026, 22:37 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 8.1-1ubuntu1.16, 8.4.4-1.1ubuntu6.7, 10.4.1-3ubuntu1.4 +1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=resoluteOther threatsAffected
  • <10.5.1-1ubuntu4.1
Fixed in
  • 10.5.1-1ubuntu4.1
Ubuntu 25.10frrpkg:deb/ubuntu/frr?arch=source&distro=questingOther threatsAffected
  • <10.4.1-3ubuntu1.4
Fixed in
  • 10.4.1-3ubuntu1.4
Ubuntu 24.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=nobleOther threatsAffected
  • <8.4.4-1.1ubuntu6.7
Fixed in
  • 8.4.4-1.1ubuntu6.7
Ubuntu 22.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=jammyOther threatsAffected
  • <8.1-1ubuntu1.16
Fixed in
  • 8.1-1ubuntu1.16
Ubuntu 20.04 LTSquaggapkg:deb/ubuntu/quagga?arch=source&distro=focalOther threatsAffected
  • 1.2.4-4build1 – 1.2.4-4ubuntu0.5
4 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=esm-apps/focalOther threatsAffected
  • 6.0.2-2build2 – 7.2.1-1ubuntu0.2+esm5
11 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches provided by Ubuntu by updating to package versions 8.1-1ubuntu1.16, 8.4.4-1.1ubuntu6.7, 10.4.1-3ubuntu1.4, or 10.5.1-1ubuntu4.1 as appropriate for your distribution. Standard system updates will include these fixes. No additional mitigation steps are required beyond applying these updates.

Description

A vulnerability in the MP_REACH_NLRI component of FRRouting (FRR) versions stable/10.0 to stable/10.6 allows authenticated attackers to cause a denial of service (DoS) by sending crafted UPDATE messages. This issue affects multiple Ubuntu package versions of FRR and has been assigned CVE-2026-37458. The vulnerability has a CVSS score of 6.5, indicating a medium severity impact focused on availability disruption.

References

Community reviews

Loading reviews…