CVE-2025-61099: Quagga · FRRouting/frr from v2.0 through v10.4.1 was discovered to contain a NULL pointer dereference
Affects quaggaSource GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 8.1-1ubuntu1.14 : patch quagga soon.
Data as of 5 Nov 2026, 23:24 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 7.5 |
|---|
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.1-1ubuntu1.14, 8.4.4-1.1ubuntu6.5, 10.4.1-3ubuntu1.1 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 25.10frrpkg:deb/ubuntu/frr?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Ubuntu 20.04 LTSquaggapkg:deb/ubuntu/quagga?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied promptly. Ubuntu has released fixed package versions: 8.1-1ubuntu1.14, 8.4.4-1.1ubuntu6.5, 10.4.1-3ubuntu1.1, and 10.5.1-1ubuntu2. Updating to these versions or later will remediate the vulnerability. Standard system updates on supported Ubuntu releases will include these fixes. No additional mitigation steps are required beyond applying the official patches.
Description
FRRouting (FRR) versions from 2.0 through 10.4.1 contain a vulnerability due to a NULL pointer dereference in the opaque_info_detail function within ospf_opaque.c. This flaw can be triggered by a crafted LS Update packet, causing a denial of service (DoS) by crashing the FRR process. The issue affects multiple Ubuntu package versions and has been assigned CVE-2025-61099 with a high severity rating. Official patches are available and have been released for affected Ubuntu versions.