Quagga: FRRouting/frr from v4.0 through v10.4.1 was discovered to contain a NULL pointer dereference via the
Affects quaggaSource GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 8.1-1ubuntu1.14 : patch quagga soon.
Data as of 5 Nov 2026, 23:24 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 7.5 |
|---|
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.1-1ubuntu1.14, 8.4.4-1.1ubuntu6.5, 10.4.1-3ubuntu1.1 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 25.10frrpkg:deb/ubuntu/frr?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Ubuntu 20.04 LTSquaggapkg:deb/ubuntu/quagga?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and users should update FRRouting to the fixed package versions: 8.1-1ubuntu1.14, 8.4.4-1.1ubuntu6.5, 10.4.1-3ubuntu1.1, or 10.5.1-1ubuntu2 as appropriate for their Ubuntu release. The vendor advisory states that a standard system update will apply the necessary fixes. No additional mitigation steps are required beyond applying these updates.
Description
FRRouting (FRR) versions from 4.0 through 10.4.1 contain a vulnerability in the show_vty_ext_link_rmt_itf_addr function in ospf_ext.c that allows a remote attacker to cause a denial of service (DoS) via a crafted OSPF packet. This issue is due to a NULL pointer dereference. The vulnerability has been assigned CVE-2025-61101 and has a CVSS v3.1 score of 7.5 (high severity). Fixed versions are available and users are advised to update to patched releases.