Skip to main content
CVE-2025-55130VulnerabilityPublished Updated

SUSE nodejs · security update for nodejs

Affects SUSE nodejsSource GCVE Database

0
Compare
Authoritative record:CVE-2025-55130· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade SUSE nodejs to 22.23.0 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.6% chance of exploitation in 30 days – higher than 77% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 22.23.0
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade nodejs to 22.23.0.

Affected software

ProductAffectedFixed in
npmnodejspkg:npm/nodejsOther threatsAffected
  • >=22.22.0 <22.23.0
Fixed in
  • 22.23.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released by Red Hat as part of the Red Hat Hardened Images update (RHSA-2026:7378). Users should apply the update to the affected Node.js packages to remediate the vulnerabilities. Refer to the Red Hat advisory at https://access.redhat.com/errata/RHSA-2026:7378 and https://images.redhat.com/ for detailed update instructions.

Description

A security update addresses multiple vulnerabilities in Node.js packages distributed by Red Hat and SUSE, including CVE-2025-55130. The update affects Red Hat Hardened Images and related Node.js RPM packages. The vulnerabilities are rated as high severity. A patch is available and has been released by Red Hat as part of their hardened images update.

References

Community reviews

Loading reviews…