Skip to main content
VulnerabilityPublished

CVE-2026-16728: undici vulnerable to downstream response desynchronization via retry interceptor

Affects undiciSource GCVE Database

0
Compare

Not known to be exploited · CVSS 4.8 Medium : upgrade to 6.28.0 when convenient.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.28.0, 7.29.0, 8.9.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade undici to 6.28.0; undici to 7.29.0; undici to 8.9.0.

Affected software

ProductAffectedFixed in
npmundiciAffected
  • <6.28.0
Fixed in
  • 6.28.0
npmundiciAffected
  • >=7.0.0 <7.29.0
Fixed in
  • 7.29.0
npmundiciAffected
  • >=8.0.0 <8.9.0
Fixed in
  • 8.9.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in undici versions 6.28.0, 7.29.0, and 8.9.0 and later; users should upgrade to these versions or newer. As workarounds, disable interceptors.retry() when dealing with untrusted upstream servers, or ensure that Content-Length headers are removed or recalculated before forwarding responses assembled or transformed by undici.

Description

Undici versions prior to 6.28.0, 7.29.0, and 8.9.0 contain a vulnerability in the interceptors.retry() feature where the response body length may not match the Content-Length header after retrying or resuming a partial response. This mismatch can cause downstream response desynchronization, connection hangs, or response corruption in clients or intermediaries that rely on the Content-Length header for framing. The issue arises when an upstream server returns a partial content response with incorrect Content-Length, and the retry interceptor retries the request, resulting in a stale Content-Length header being forwarded. The vulnerability is patched in undici versions 6.28.0, 7.29.0, and 8.9.0 and later.

References

Community reviews

Loading reviews…