vLLM after 0.24.0 and before 0.31.0 contains a memory exhaustion vulnerability in MOSS-Audio model serving that caches
Affects vllmSource GCVE Database
Not known to be exploited · CVSS 8.7 High : upgrade to 0.31.0 soon.
Data as of 4 Nov 2026, 11:17 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.7 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 7.5 |
- Patch
- Available – fixed in 0.31.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade vllm to 0.31.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPIvllmpkg:pypi/vllmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade vLLM to version 0.31.0 or later, where this vulnerability is fixed. Since a patch is available, applying the official fix is the recommended mitigation. No other vendor advisory mitigation or workaround is indicated.
Description
vLLM versions after 0.24.0 and before 0.31.0 have a memory exhaustion vulnerability in the MOSS-Audio model serving component. This flaw arises because the system caches a processor for every distinct mm_processor_kwargs value in an unbounded dictionary. Unauthenticated attackers can exploit this by sending distinct or oversized mel_config values to the /tokenize endpoint, bypassing API key protections, leading to host memory exhaustion and crashing the API process. The vulnerability is fixed in version 0.31.0.