vLLM before 0.31.0 contains a cache aliasing vulnerability that allows authenticated attackers to collide shared cache
Affects vllmSource GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 0.31.0 soon.
Data as of 4 Nov 2026, 11:17 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 7.1 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 6.5 |
- Patch
- Available – fixed in 0.31.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade vllm to 0.31.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPIvllmpkg:pypi/vllmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in vLLM version 0.31.0 that fixes this cache aliasing vulnerability. Users should upgrade to version 0.31.0 or later to remediate this issue. No additional mitigation steps are indicated.
Description
vLLM versions prior to 0.31.0 contain a cache aliasing vulnerability that allows authenticated attackers to cause collisions in shared cache keys by manipulating caller-controlled values such as EXIF ImageID or cache_salt. This can lead to attackers receiving cached processed media from other requests or reusing key-value state improperly. The vulnerability is fixed in version 0.31.0.