Skip to main content
CVE-2026-115911VulnerabilityPublished Updated

Vllm: From 0.19.0 until 0.32.0, authenticated callers can supply a request chat template when no server-side

Affects vllmSource GCVE Database

0
Compare
Authoritative record:CVE-2026-115911· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium : upgrade to 0.32.0 when convenient.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.16.5
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.32.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade vllm to 0.32.0.

Affected software

ProductAffectedFixed in
PyPIvllmpkg:pypi/vllmOther threatsAffected
  • 0.19.0 – 0.31.0
  • >=0.19.0 <0.32.0
19 affected builds
Fixed in
  • 0.32.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in vLLM version 0.32.0. Users should upgrade to version 0.32.0 or later to remediate this issue. No additional mitigation is indicated by the vendor advisory.

Description

vLLM versions from 0.19.0 up to but not including 0.32.0 contain a vulnerability where authenticated users can supply a request chat template if no server-side template is configured. This allows a malicious template to be compiled and rendered without execution limits, potentially causing denial of service by blocking response handling or exhausting server memory. Harmony models are not affected. The issue is fixed in version 0.32.0.

References

Community reviews

Loading reviews…