When a request to the Airflow core API carries both a session cookie and an explicit Authorization: Bearer token
Source GCVE Database
Not known to be exploited · CVSS 4.2 Medium : upgrade to 3.3.2 when convenient.
Data as of 5 Nov 2026, 00:01 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 4.2 |
|---|
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.3.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade Apache Airflow and org.apache.airflow/airflow-core and apache-airflow-core to 3.3.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Airflowapache-airflow-core | Affected
| Fixed in
|
Mavenorg.apache.airflow/airflow-corepkg:maven/org.apache.airflow/airflow-coreOther threats | Affected
| Fixed in
|
PyPIapache-airflow-corepkg:pypi/apache-airflow-coreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users of Apache Airflow 3.3.0 and 3.3.1 should upgrade to version 3.3.2 or later, where the issue is fixed by ensuring the caller identity is resolved from the explicitly supplied credential (bearer token) whenever present. Deployments should also consider isolating the Airflow UI domain from other applications to reduce exposure to cookie tossing or cross-site scripting attacks. No other specific mitigations are indicated.
Description
Apache Airflow versions 3.3.0 and 3.3.1 contain a vulnerability where requests to the core API that include both a session cookie and an Authorization: Bearer token incorrectly prioritize the session cookie over the bearer token. This leads to the request being executed and logged as the cookie's user rather than the explicitly presented bearer token user. Exploitation requires an attacker to place a valid session cookie in the victim's client, such as via cookie tossing or cross-site scripting in co-hosted domains. The issue causes principal confusion and misattributed audit logs but does not directly escalate privileges. Upgrading to Airflow 3.3.2 or later resolves this issue.
References
- nvd.nist.gov/vuln/detail/CVE-2026-82355 (opens in a new tab)
- github.com/apache/airflow/pull/72225 (opens in a new tab)
- github.com/apache/airflow/pull/72723 (opens in a new tab)
- lists.apache.org/thread/3p7zpdvv40tn01m0xk5mt2rxg88mw8w1 (opens in a new tab)
- openwall.com/lists/oss-security/2026/09/21/4 (opens in a new tab)