A medium-severity authorization bypass vulnerability exists in iFlytek astron-agent up to version 1.1.2. The flaw affects the FileInfoV2Service.listKnowledgeByPage function via manipulation of the argument space-id, allowing unauthorized access. The vulnerability can be exploited remotely. Public exploit code is available, but no vendor response or patch has been provided.
A NULL pointer dereference vulnerability in gssproxy allows any local user to crash the daemon by sending a GSSX_INIT_SEC_CONTEXT request missing the target_name field. This causes the daemon to crash and not restart automatically, resulting in a persistent denial of service that affects dependent services such as Kerberized NFS and IdM.
An SQL Injection vulnerability exists in CRM SOFTTRADE Infotech (softtradeindia) version 1.0, allowing a remote attacker to execute arbitrary code via the login page.
A vulnerability in iFlytek astron-agent up to version 1.1.2 affects the DDL Whitelist Handler component, specifically in the file core/memory/database/api/v1/exec_ddl.py. This flaw causes an incomplete blacklist, potentially allowing unauthorized actions. The vulnerability can be exploited remotely and has publicly disclosed exploit code. The vendor has not responded to the disclosure. The CVSS score is 7.3, indicating a high severity.
A local information disclosure vulnerability exists in Kameleo versions up to 5.0.1.26 in the ListProfiles function of the Profile Controller component. This flaw allows an attacker with local access to obtain information improperly. The issue is resolved by upgrading to version 5.2.0.
A vulnerability in the hackney_conn component of the benoitc hackney HTTP client allows a malicious HTTP server to exhaust client memory by sending an oversized or highly compressed response body. The client buffers the entire response without limits, and with auto decompression enabled, decompresses the entire body at once, leading to potential resource exhaustion. This affects hackney versions from 2.0.0-beta.1 up to but not including 4.9.0.
A vulnerability in the WCH CH340/CH341 USB-to-Serial Windows Driver setup package CH341SER.EXE version 4.0 allows a local attacker to escalate privileges on the affected system.
Apache SIS versions 0.7 through 1.6 have a vulnerability where the software opens linked files from data files without properly restricting their paths. This can lead to opening local files outside the intended directory. The vulnerability affects specific geographic data formats including GML, WKT with datum shift grids, and Landsat GeoTIFF bands. The risk of sensitive information leakage is low because the software stops reading at the first parsing error if the file format is unexpected. Version 1.7 of Apache SIS fixes this issue by restricting file paths to the same directory or a predetermined directory for datum shift grids.
The MongoDB Shell (mongosh) versions prior to 2.14.0 rely on a Node.js runtime that includes a TLS root certificate store containing recoverable eMudhra intermediate CA certificates. This reliance introduces a security vulnerability identified as CVE-2026-115930. The issue can be resolved by updating mongosh to version 2.14.0 or later, which bundles Node.js 24.22.1 or newer. For installations via npm, the Node.js runtime on the host must be updated separately.
The TTLock Android application versions before 9.8.260718 and associated smart-lock firmware contain a vulnerability due to a hardcoded static AES key. This flaw allows attackers within Bluetooth range to decrypt the per-pairing session key during BLE pairing. Exploitation enables unauthorized actions such as unlocking the device, adding fingerprints or access codes, and performing administrative tasks without user authentication or interaction.
A SQL injection vulnerability exists in the SQL storage module of Apache SIS versions 1.0 through 1.6 inclusive. The issue arises when sorting a stream of features, as the sort clause is copied after ORDER BY without properly quoting identifier characters, allowing crafted input to inject SQL code. This vulnerability is fixed in version 1.7.
A weakness in Kameleo up to version 5.0.1.26 affects the Local API component, specifically the /profiles file, allowing remote attackers to cause information disclosure. The issue is mitigated by upgrading to version 5.2.0.
Frappe CRM app versions before 1.89.1 have a missing authorization vulnerability that allows authenticated low-privileged users to access CRM Lead records they should not be able to see. This occurs because the get_contact_by_phone_number API endpoint performs raw database queries without enforcing permission checks, enabling unauthorized disclosure of sensitive lead data by supplying a known phone number.
Mattermost versions up to 11.9, including 11.1.9, 11.5.8, and 11.10.7.0, contain a vulnerability where the Zoom chat line length is not properly validated before slicing. This flaw allows an authenticated attacker to crash the Agents plugin by summarizing a Zoom chat transcription with short continuation lines.
danmu_api versions before 1.21.7 have an authentication bypass vulnerability that allows unauthenticated attackers to modify server environment configurations if the default TOKEN is used and ADMIN_TOKEN is unset. Exploitation involves sending POST requests to specific API endpoints to set ADMIN_TOKEN, lock out legitimate operators, redirect server URLs potentially causing SSRF, and trigger redeployment.
Objenesis versions before 3.6 have a type confusion vulnerability due to instantiator caching keyed on class name, which can cause objects from one class loader to be substituted for those of another. This leads to ClassCastException failures when newInstance() returns objects of the wrong class.
NXP MCUXpresso SDK USB middleware versions before 2.13.0 contain an out-of-bounds read vulnerability in the USB_DeviceCdcRndisSetCommand() function. This flaw arises because the function trusts a host-supplied informationBufferOffset, allowing a malicious USB host to send crafted RNDIS SET messages with out-of-range offsets. Exploiting this vulnerability can lead to disclosure of device memory.
NXP MCUXpresso SDK USB middleware versions before 2.13.0 contain a heap buffer overflow vulnerability in the host audio, video, and CDC class drivers. This flaw arises because the drivers trust device-supplied bNumEndpoints and bLength values without proper validation. A malicious USB device can exploit this by supplying crafted descriptors that overflow the fixed-size epList array, leading to heap memory corruption. This can result in code execution or denial of service on the affected system.
A security flaw in Kameleo up to version 5.3.1 affects the CookieController.ListCookies function, allowing remote attackers to manipulate the 'guid' argument to disclose information. The vulnerability is classified as CWE-200 (information disclosure). The vendor was contacted but did not respond, and no patch or fix information is available. The CVSS 3.1 base score is 4.3, indicating a medium severity issue.
A code injection vulnerability exists in AllenAI AllenNLP up to version 2.10.1 in the Registrable.resolve_class_name function. This flaw allows remote attackers to manipulate the Type argument, potentially leading to code execution. The vulnerability affects unsupported versions, and no vendor response or patch is available. Public exploit code exists, increasing the risk of exploitation.