PJSIP pjproject versions 2.17 and earlier have an improper certificate validation vulnerability in the OpenSSL and GnuTLS backends. The flaw involves incorrect handling of DNS SubjectAltName values containing embedded NUL bytes, allowing an attacker with a specially crafted certificate from a trusted issuer to impersonate a target server during TLS verification. This can lead to interception of SIP sessions and theft of REGISTER credentials. The mbedTLS backend is not affected. No fixed version is currently available.
PJSIP is a free and open source multimedia communication library written in C. In 2.17 and earlier, the PJSIP AVI parser in pjmedia/src/pjmedia/avi_player.c uses an input-file video chunk length as the number of bytes copied into a frame buffer whose capacity is derived from the declared media dimensions. A crafted AVI file can therefore cause an attacker-controlled out-of-bounds write past the heap allocation when an application plays the file or pulls its frames. The existing size assertion does not protect production release builds, where assertions are disabled. Typical local playback can crash the process, while applications that accept untrusted AVI sources expose a stronger memory-corruption condition. No fixed version is available as of this review.
CVE-2026-42225 is a high-severity vulnerability in the pjsip pjproject library prior to version 2.17. On GnuTLS builds, the SIP TLS transport component can accept connections with invalid or untrusted certificates even when certificate verification is explicitly enabled. This improper certificate validation issue is identified as CWE-295. The vulnerability has been patched in version 2.17. No known exploits in the wild have been reported.
PJSIP is a free and open source multimedia communication library written in C. In 2.16 and earlier, there is an integer overflow in media stream buffer size calculation when processing SDP with asymmetric ptime configuration. The overflow may result in an undersized buffer allocation, which can lead to unexpected application termination or memory corruption This vulnerability is fixed in 2.17.
CVE-2026-41415 is an out-of-bounds read vulnerability in the pjsip pjproject library versions 2.16 and earlier. It occurs when parsing a malformed Content-ID URI in a SIP multipart message body due to insufficient length validation, allowing reads beyond buffer boundaries. This vulnerability has a medium severity with a CVSS score of 6.7. The issue is fixed in version 2.17 of pjproject.
PJSIP is a free and open source multimedia communication library written in C. In 2.16 and earlier, a stack buffer overflow exists in pjsip_auth_create_digest2() in PJSIP when using pre-computed digest credentials (PJSIP_CRED_DATA_DIGEST). The function copies credential data using cred_info->data.slen as the length without an upper-bound check, which can overflow the fixed-size ha1 stack buffer (128 bytes) if data.slen exceeds the expected digest string length.
CVE-2026-40614 is a heap-based buffer overflow vulnerability in the pjsip pjproject library versions 2.16 and earlier. It arises from insufficient buffer size validation when decoding Opus audio frames, where the allocated buffer is smaller than the maximum possible encoded frame size. This causes unsafe memory copying operations leading to a heap overflow. The vulnerability has a high severity with a CVSS score of 8.5. No official patch or remediation guidance is currently available from the vendor.
PJSIP is a free and open source multimedia communication library written in C. Prior to version 2.17, a heap out-of-bounds read vulnerability exists in PJSIP's VP9 RTP unpacketizer that occurs when parsing crafted VP9 Scalability Structure (SS) data. Insufficient bounds checking on the payload descriptor length may cause reads beyond the allocated RTP payload buffer. This issue has been patched in version 2.17. A workaround for this issue involves disabling VP9 codec if not needed.
PJSIP is a free and open source multimedia communication library written in C. Versions 2.16 and below have a cascading out-of-bounds heap read in pjsip_multipart_parse(). After boundary string matching, curptr is advanced past the delimiter without verifying it has not reached the buffer end. This allows 1-2 bytes of adjacent heap memory to be read. All applications that process incoming SIP messages with multipart bodies or SDP content are potentially affected. This issue is resolved in version 2.17.
PJSIP is a free and open source multimedia communication library written in C. Versions 2.16 and below have a Heap-based Buffer Overflowvulnerability in the DNS parser's name length handler. Thisimpacts applications using PJSIP's built-in DNS resolver, such as those configured with pjsua_config.nameserver or UaConfig.nameserver in PJSUA/PJSUA2. It does not affect users who rely on the OS resolver (e.g., getaddrinfo()) by not configuring a nameserver, or those using an external resolver via pjsip_resolver_set_ext_resolver(). This issue is fixed in version 2.17. For users unable to upgrade, a workaround is to disable DNS resolution in the PJSIP config (by setting nameserver_count to zero) or to use an external resolver implementation instead.
CVE-2026-32942 is a high-severity use-after-free vulnerability in the pjsip pjproject multimedia communication library, affecting versions prior to 2.17. The flaw arises from race conditions during ICE session destruction and callback execution, leading to heap memory corruption. Exploitation requires no authentication or user interaction and can result in high confidentiality and integrity impacts, such as remote code execution or denial of service. The vulnerability has been fixed in version 2.17. Organizations using vulnerable versions of pjproject in VoIP or multimedia applications should urgently update to mitigate risks. No known exploits are currently reported in the wild. Countries with significant pjproject deployment and strategic VoIP infrastructure are at higher risk.
PJSIP is a free and open source multimedia communication library written in C. Prior to version 2.17, a heap use-after-free vulnerability exists in PJSIP's event subscription framework (evsub.c) that is triggered during presence unsubscription (SUBSCRIBE with Expires=0). This issue has been patched in version 2.17.
PJSIP is a free and open source multimedia communication library written in C. Prior to version 2.17, there is a stack buffer overflow vulnerability when pjmedia-codec parses an RTP payload contain more frames than the caller-provided frames can hold. This issue has been patched in version 2.17.
PJSIP is a free and open source multimedia communication library. Prior to version 2.16, Opus PLC may zero-fill the input frame as long as the decoder ptime, while the input frame length, which is based on stream ptime, may be less than that. This issue affects PJSIP users who use the Opus audio codec in receiving direction. The vulnerability can lead to unexpected application termination due to a memory overwrite. This issue has been patched in version 2.16.
PJSIP is a free and open source multimedia communication library written in C. A buffer overflow vulnerability in versions 2.13 and prior affects applications that use PJSIP DNS resolver. It doesn't affect PJSIP users who do not utilise PJSIP DNS resolver. This vulnerability is related to CVE-2022-24793. The difference is that this issue is in parsing the query record `parse_query()`, while the issue in CVE-2022-24793 is in `parse_rr()`. A patch is available as commit `d1c5e4d` in the `master` branch. A workaround is to disable DNS resolution in PJSIP config (by setting `nameserver_count` to zero) or use an external resolver implementation instead.