A vulnerability was determined in DeepSeek Harness up to 0.2.0-rc.2. This issue affects some unknown processing of the file packages/client/connection/src/browser-auth.ts of the component Browser Auth. This manipulation causes improper authorization. The attack can be initiated remotely. The vendor was contacted early about this disclosure but did not respond in any way.
OpenHands Software Agent SDK before 1.52.0 contains an unauthenticated remote code execution vulnerability where the DockerWorkspace and Apptainer workspace launchers bind the sandbox agent server to all network interfaces (0.0.0.0) with an empty session_api_keys list, disabling authentication by default. Attackers who can reach the published container port can send unauthenticated HTTP and WebSocket requests to execute arbitrary shell commands as root in the sandbox, access the mounted workspace, and read plaintext secrets from the secrets store.
A vulnerability was found in DeepSeek Harness up to 0.1.0-rc.5. This vulnerability affects the function createContext of the file packages/extensions/cordis-host-runner/src/sandbox.ts. The manipulation results in sandbox issue. It is possible to launch the attack remotely. The vendor was contacted early about this disclosure but did not respond in any way.
**UNSUPPORTED WHEN ASSIGNED** Authorization bypass in Apache Vysper, all versions.
Apache Vysper is an XMPP (Jabber) server library. Its XEP-0077 (In-Band Registration) implementation is missing an authentication check, allowing any authenticated user to compromise other accounts.
As this project is retired, we do not plan to release a version that fixes this issue. Users are recommended to find an alternative.
CVE-2026-115721 is a high-severity vulnerability in Apache Vysper, an XMPP server library. It involves unbounded resource allocation during XML parsing, which can lead to an out-of-memory condition. This affects all versions of Apache Vysper. The project is retired and no fixes will be released. Users are advised to migrate to alternative solutions.
Open5GS versions 2.6.1 through 2.8.0 have an out-of-bounds read vulnerability in the parse_scheme_output() function during SUCI de-concealment. This flaw arises from incomplete length validation, allowing remote unauthenticated UEs or SBI peers to submit a crafted SUCI with a 42-byte scheme output to a UDM, causing a heap over-read beyond the buffer.
Open5GS versions 1.3.0 through 2.8.0 have a heap out-of-bounds write vulnerability in the parse_multipart() function. This flaw allows unauthenticated attackers to corrupt memory by sending a crafted multipart/related request with an empty multipart boundary to the SBI interface of any network function, causing a buffer overflow and potential crash.
CVE-2026-116542 is a vulnerability in netty-tcnative versions before 2.0.84.Final that allows remote unauthenticated clients to spoof SNI hostnames by exploiting improper handling of Unicode encoding in JNI NewStringUTF decoding. Attackers can use overlong encodings in the ClientHello server_name field to manipulate SNI-based certificate selection, access control decisions, and logging.
CVE-2026-116541 is a denial of service vulnerability in netty-tcnative versions before 2.0.84.Final. The flaw occurs in the tcn_write_to_bytebuffer BIO write callback, which incorrectly calculates bytes consumed. This can be exploited by remote TLS 1.3 peers sending queued post-handshake records such as NewSessionTicket or KeyUpdate, causing truncated flights, connection failures, or JVM process aborts.
A use-after-free vulnerability exists in netty-tcnative versions 2.0.66.Final through 2.0.83.Final when built against OpenSSL 3.x. The flaw occurs during TLS session ticket key rotation, where OpenSSL may read freed HMAC keys, potentially causing crashes or corruption in ticket processing.
CVE-2026-116539 is a heap buffer overflow vulnerability in netty-tcnative before version 2.0.84.Final. It occurs in the tcn_write_to_bytebuffer BIO callback due to improper handling of the ring buffer write index. Remote TLS peers can exploit this during handshake, renegotiation, or post-handshake messages to trigger an out-of-bounds memory copy, causing the JVM process to crash.
HtmlSanitizer versions before 9.2.1039 and prereleases before 10.0.1037-beta contain a cross-site scripting (XSS) vulnerability. The function SanitizeDom(string) does not sanitize attributes on the html and body wrapper elements, allowing attackers to inject a second html or body tag with event handlers such as onload. This can lead to script execution when the application renders the serialized document or body outer HTML. The vulnerability has a low CVSS score of 2.3 and is fixed in versions 9.2.1039 and 10.0.1037-beta.
CVE-2026-116489 is a type confusion vulnerability in timescale pgvectorscale versions before 0.9.1. It allows low-privileged database users with CREATE privilege on the vectorscale schema to corrupt memory by shadowing pgvector's vector type or operators. Exploitation involves pre-creating shadow objects and querying DiskANN indexes with crafted values, leading to out-of-bounds memory reads and writes. This can result in memory disclosure, server crashes, or privilege escalation. The vulnerability is fixed in version 0.9.1.
A malicious file identified by the SHA-256 hash 5bb52bd682510c1fdc91025512a92c0e2323c885664e65ad32f0fbb426940469 was observed by OffSeq Mirage honeypot sensors on 2026-10-26. The file was detected four times during attacker activity involving the T1105 technique (Ingress Tool Transfer), indicating it was used to stage or deliver a malicious payload such as a dropper, web shell, miner, or post-exploitation tool. The malicious activity was traced to attacker infrastructure located in PS. Organizations are advised to match this hash against their environments and security feeds to detect potential compromise.
A malicious file identified by the SHA-256 hash a863e21577e54cd763729803a621804da4b5030afa35bcf879ea3b3413488a66 was observed by OffSeq Mirage honeypot sensors during attacker activity on 2026-10-26. This file is associated with CVE-2026-109618 and linked to the MITRE ATT&CK technique T1105 (Ingress Tool Transfer). The file likely represents a malicious payload such as a dropper, web shell, miner, or post-exploitation tool used during the attack. The activity was traced back to attacker infrastructure in PS. Organizations are advised to match this hash against files in their environments and threat intelligence feeds.
CVE-2026-85297 is a vulnerability in Google Cloud Run MCP versions prior to 1.11.0 that allows bucket squatting. This flaw enables attackers to intercept and access proprietary source code, execute arbitrary code, and exfiltrate data. The issue is resolved in version 1.11.0 and later.
The PHP2Shell vulnerabilities (CVE-2026-109618 and CVE-2026-109619) are critical flaws in the PHP engine allowing unauthenticated remote code execution. Multiple industrial vendors including Siemens, Schneider Electric, ABB, and others have confirmed that some of their products are affected. Patches for PHP were released on October 21, 2026, shortly after exploitation attempts began. Several vendors have released or are preparing patches for affected products, while some continue to assess impact or provide mitigations. The vulnerabilities have been actively targeted in the wild, with millions of exploitation attempts reported and confirmed attacks on honeypots.
CVE-2026-99099 addresses a vulnerability in the Linux kernel related to AMD processors where the processor may fail to invalidate a TLB entry when executing an INVLPGB/TLBSYNC instruction pair. This issue is known as AMD TLBI Erratum #1718. The Linux kernel has implemented a software workaround to detect this erratum and mitigate it when a microcode fix is not available.