Skip to main content
VulnerabilityPublished Updated

CVE-2023-33246: Apache RocketMQ · Code Injection

Affects Apache RocketMQSource CVE Database V5

0

Exploited in the wild · KEV due 27 Sep 2023 · public exploit available (Metasploit) · 96% EPSS : upgrade to 5.1.1 now.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
EPSS
96.5% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.1.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 24 May 2023

  2. Weaponised: evidence found.

    1 Metasploit module

  3. Exploited in the wild: evidence found.

    Listed in CISA KEV 105 days after disclosure

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by Apache Software Foundation

    , 3 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. , 105 days after disclosure

  4. KEV remediation due

    US federal deadline

    , 126 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade org.apache.rocketmq/rocketmq to 5.1.1.

Affected software

ProductAffectedFixed in
Mavenorg.apache.rocketmq/rocketmqpkg:maven/org.apache.rocketmq/rocketmqOther threatsAffected
  • <5.1.1
Fixed in
  • 5.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

CVE-2023-33246 is a critical remote code execution vulnerability in Apache RocketMQ versions 5.1.0 and below. The vulnerability arises because several RocketMQ components exposed on the extranet lack proper permission verification, allowing attackers to exploit the update configuration function or forge protocol content to execute arbitrary commands with the privileges of the RocketMQ process. This flaw affects NameServer, Broker, and Controller components. No authentication or user interaction is required, and the vulnerability has a CVSS score of 9.8, indicating a severe risk to confidentiality, integrity, and availability. Users are strongly advised to upgrade to RocketMQ 5.1.1 or above, or 4.

References

Community reviews

Loading reviews…