CVE-2026-22225: TP-Link Systems Archer BE230 v1.2 · OS Command Injection
Affects TP-Link Systems Archer BE230 v1.2Source CVE Database V5
Not known to be exploited · CVSS 8.5 High : upgrade to 1.2.4 Build 20251218 rel.70420 soon.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 2.7% chance of exploitation in 30 days – higher than 86% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.2.4 Build 20251218 rel.70420, < 1.5.3 Build 20260209 rel. 71108
CVSS:4.0/AV:A/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:LExploitation evidence
Disclosed: evidence found.
CVE published 2 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade Archer to 1.2.4 Build 20251218 rel.70420 (BE230 v1.2) or < 1.5.3 Build 20260209 rel. 71108 (AX53 v1.0).
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| TP-Link Systems Inc.Archer BE230 v1.2 | Affected
| Fixed in
|
| TP Link Systems Inc.Archer AX53 v1.0 | Affected
| Fixed in
|
AI-suggested
To mitigate CVE-2026-22225, organizations should: 1) Immediately verify the firmware versions of Archer BE230 and AXE75 devices and upgrade to versions 1.2.4 (or later) for BE230 and 1.5.3 (or later) for AXE75 once available from TP-Link. 2) Restrict administrative access to the router management interface and VPN Connection Service to trusted networks and IP addresses only, using network segmentation and firewall rules. 3) Enforce strong, unique administrator passwords and consider multi-factor authentication if supported to reduce risk of credential compromise. 4) Monitor device logs and network traffic for unusual activity indicating attempted or successful exploitation. 5) Disable or limit VPN Connection Service if not required to reduce attack surface. 6) Regularly audit and update device firmware and configurations as part of network security hygiene. 7) Educate administrators on the risks of credential theft and the importance of secure management practices. These steps go beyond generic advice by emphasizing access restrictions, monitoring, and proactive firmware management tailored to this vulnerability.
Description
A command injection vulnerability may be exploited after the admin's authentication in the VPN Connection Service on the Archer BE230 v1.2 and Archer AXE75 v1.0. Successful exploitation could allow an attacker to gain full administrative control of the device, resulting in severe compromise of configuration integrity, network security, and service availability. This CVE covers one of multiple distinct OS command injection issues identified across separate code paths. Although similar in nature, each instance is tracked under a unique CVE ID. This issue affects Archer BE230 v1.2 < 1.2.4 Build 20251218 rel.70420 and Archer AXE v1.0 < 1.5.3 Build 20260209 rel.71108.
References
- tp-link.com/us/support/download/archer-be230/v1.20/ (opens in a new tab)
- tp-link.com/en/support/download/archer-be230/v1.20/ (opens in a new tab)
- tp-link.com/sg/support/download/archer-be230/v1.20/ (opens in a new tab)
- tp-link.com/us/support/faq/4935/ (opens in a new tab)
- tp-link.com/us/support/download/archer-axe75/v1/ (opens in a new tab)
- tp-link.com/en/support/download/archer-axe75/v1/ (opens in a new tab)